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Упражнение 3 

Автоматизиране на обработката на данни в Excel 

 

Цели: 

 Да се усвоят и да се приложат възможностите за 
автоматизиране на рутинни действия при обработка на 
информация. 

 Да се разгледат възможностите на макросите за 
обобщаване на отчети от продажбите във фирма. 

  Да се създадат графики за визуално изобразяване на 
обобщената информация. 

 

Ключови думи: макрос, автоматизирана обработка на 

информация, обобщаващи макроси, бутони, коригиране на 

съдържанието на макросите. 

 

Ресурси: За реализация на настоящото упражнение е нужно 

наличие на PC с инсталиран програмен продукт Excel и 

надеждна и сравнително бърза  връзка с Интернет. 

 
 

Създаване на макроси за автоматизиране на обработката на 

Информацията. 

Задача 1 
Да се създадат макроси за автоматично обобщаване на 

данните от оборота на магазините на фирма „Прометей ЕООД” 
представени в У3-turnover.xls. Обобщаването да се извършва по 
критерий магазин и по критерий месец. Да се създаде макрос, с 
който да се връща таблицата в изходно положение. 
Указания за изпълнение 
Създаването на макроси в EXCEL може да стане чрез изписване 

на програмен код в прозореца на Visual Basic Editor или чрез включване на 
командата Record Macro, която генерира и записва програмен код на Visual 
Basic до момента нейното изключване. 

Програмният код става част от файла и може да бъде стартиран по 
желание на потребителя от прозореца Macro или чрез натискане на специално 
създаден бутон, на който е присвоен самия макрос. Това позволява записаните 
в макроса действия да бъдат изпълнявани всеки път, когато към таблицата се 
добавят нови данни и е необходимо да се извършат същите действия по 
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обработката им. По този начин се спестява време за извършване на рутинни 
операции и се избягват евентуални грешки при повторението на тези операции. 
Записването на макроса се включва от: View→ Macros → Record Macro … 

 

 
Фигура 3.1 Диалогов прозорец Record Macro 

В прозореца който се отваря (фиг. 3.1) се задава името на макроса, под 
което се описва програмният код и с което по късно се „извиква” макроса. По 
подразбиране името на макроса е Macro1, но може да се смени на 

ОбобщаванеПоМагазини. Смяна на името и натискане на бутнон   
прозорецът Record Macro изчезва. От този момент нататък всяко действие, 

което се извършва с клавиатурата или мишката се записва като програмен код 
в Макроса ОбобщаванеПоМагазини. Съдържанието му се показва във Visual 
Basic Editor, което ще бъде описано по-долу. 

Сега следва да се извършат последователно действията, които желаем 
да опишем в макроса. Действията целят да се направи обобщена таблица по 
критерий Годинa и Магазин, в която да се изчислят оборотите на всеки магазин 

за всяка година. За целта най-напред трябва таблицата да се подреди по 
критерий Годинa и Магазини:  

Data→ Sort (фиг. 3.2.). 

 
Фигура 3.2 Посочване на критерии за сортиране. 
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Следващата стъпка е да се включи команда Subtotal с параметри: 
Обобщаване на данните при всяка промяна в колона Магазин и създаване на 
сума под колона Оборот чрез включване на командата от: Data → Subtotal и 

параметрите, посочени на фиг. 3.3. Така в таблицата се получава нужното ни 

обобщаване и можем да включим ниво  , при което ще се скрият началните 
данни и ще останат обобщаващите редове, които показват годишните обороти 
за всеки от магазините. Резултатът от командата е посочен на фиг. 3.4. 

 
Фигура 3.3 Настройка на критериите 
на Subtotal 

 
Фигура 3.4 Получените данни от 
Subtotal 

 
Вижда се, че при създаване на обобщена таблица колони B, C и D,не 

съдържат информация, поради което е подходящо те да бъдат Скрити (Hide) и 
да се получи прегледна таблица. За да се изпълни това действие: 
1).Маркират се колони B:D; 
2).Натиска се десния бутон на мишката (върху буквите на избраните колони) за 
извикване на помощното меню  
3).Посочва се команда Hide (Скрий). 

Резултатът е обобщена таблица с две колони – Магазин и Оборот. В този 
момент трябва да се спре процесът на запис на действията в макрос чрез 
натискане на бутона  Stop Recording.(фиг. 3.5) 

 
Фигура 3.5 Съдържание на менюто Macros 

За да видим създадения програмен код трябва да се извика View→ 
Macro →View Macros, което отваря прозореца за управление на макросите 
(фиг. 3.6.) 
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Фигура 3.6 Диалогов прозорец на Macro 

В този прозорец се посочва името на макроса и се натиска бутон 

 с който се отваря Microsof Visual Basic в който можем да видим 

програмния код на всички действия, описани в макроса 
ОбобщаванеПоМагазини фиг. 3.7. Кодът който генерира програ мата е на 

езика Visual Basic for Applications и е оформен в самостоятелна процедура, 
която става част от електронната таблица. Процедурата започва със Sub 
следвана от името на процедурата и завършва с End Sub. Вътре в 
процедурата има текст - коментар, които е само за информация и не 
представлява програмен код. Такъв текст започва със символа (‘) и е оцветен в 
зелено.
  

 
Фигура 3.7 Програмен код в Microsof Visual Basic на втори макрос. 

Всяко действие извършено при записа на макроса се описва под 
формата на команда в отделен параграф (Range; Selection; ActiveSheet; 
Columns и Selection). Когато командата е с голямо съдържание, текстът от нея 
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продължава на нов ред, като пренасянето се извършва със символа (_) и новия 
ред от параграфа е с 4 символа по-навътре. Това се прави за прегледност при 
четенето на програмния код. Ако се вгледаме по-задълбочено в програмния 
код, ще разберем, че той е съставен на основата на английския език, но си има 
строги правила при писане, които задължително се спазват. За радост 
програмата с която се генерира макроса спазва тези правила и кодът, който 
генерираме чрез запис на командите отговаря на изискванията. 

Следващият макрос, който ще бъде създаден ще върне таблицата в 
изходно положение – ще се покажат скритите колони и ще се изключи 
обобщаването на таблицата по критерий магазин. 

Стъпките които трябва да изпълнят са: 
1). Включва се записването на макроса: View → Macro → Record  Macro; 
2). Задава се име на макроса ИзходноПоложение (в прозореца Record Macro 

фиг. 3.1); 
3). Маркират се колони А:Е (за да се покажат скритите между тях редове); 

4). Натиска се десния бутон на мишката за извикване на помощното меню; 
5). Посочва се команда Unhide – (Открий); 
6). Изключва се обобщаването на таблица от Data → Subtotal и се натиска 

бутона от прозореца на фиг. 3.3; 

7). Изключва се записването на макроса от бутона . 
 

Резултатът от действията е 
макрос, който възстановява 
началното положение на таблицата 
(фиг. 3.8). 

В макроса се виждат трите 
действия описани в програмния код: 
Columns("A:E").Select – Маркиране 
на колони от А до Е 
Selection.EntireColumn.Hidden = 
False – Показват се скритите редове 
Selection.RemoveSubtotal – 
Изключва се обобщаването на 
таблицата. 

 
Фигура 3.8 Получени резултати. 

Третият макрос ще обобщава данните по критерий месец. Подобно на 

първия макрос, за да се обобщят данните по избрания критерий трябва 
предварително таблицата да се подреди. 
1). Включва се записването на макроса: View → Macros → Record  Macro… 
2). Задава се име на макроса ОбобщаванеПоМесец (в прозореца Record Macro 

– аналогично на фиг. 3.2) 
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3). Сортира се таблицата по критерии Година и след това Месец. (фиг. 3.9.).

 
Фигура 3.9 Сортиране по критерии Година и  Месец 

Подреждането се извършва най-напред по критерий 
Година а след това по критерий Месец, за да се 
осигури отделно обобщаване на данните по месеци, но 
за всяка година. 
4). Обобщаване на данните с команда: Data → Subtotal 
и параметри от фиг. 3.10. 
5). Включване на ниво за да се скрият детайлите от 
първичната таблица. 
6). Маркиране и скриване на колони C:D 
7). Скриване на колона А 
8). Спиране на записа на макроса от бутона 

 
Фигура 3.10 Настройка  
на критериите на Subtotal 
 
Резултатът е макрос с посочения във фиг. 3.11 програмен код. 

 
Фигура 3.11 Програмен код в Microsof Visual Basic на трети макрос. 

 
Така вече имаме създадени 3 макроса с които можем да извършваме 
обобщаване на данните от таблицата и връщане в изходното и положение.  
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Фигура 3.12 Списък на създадените 
макроси. 
 

Стартирането на макросите става 
от: 
View → Macros →View  Macros. При 

извикването на тази команда на 
екрана се появява списък с 
макросите, които принадлежат на 
таблицата (фиг. 3.12).  
При маркирането на един от тях и 

натискане на бутона , Excel 
автоматично изпълнява запасните в 
макроса действия. 
За да върнете в изходно положение 
таблицата изберете от списъка 
макроса ИзходноПоложение и 
натиснете бутона Run. 

 Задача 2  
Да се създадат бутони в таблицата с които да се включва всеки от 
макросите, създадени в задача 1. 
Указания за изпълнение 

Създаването на бутони в таблицата е удобен начин да се 
стартират вече създадени макроси. Така работата с макросите се 
облекчава и не става нужда да се търсят в списъка с макроси. 

За да създадем бутон в таблицата е необходимо да добавим 
инструмента Button чрез изпълнение на следните стъпки: 
1).На празно място на лентата с инструменти чукнете десен бутон на мишката: 
2). От появилото се контекстно меню избираме  

 ; 
3).От появилия се диалогов прозорец маркираме Button (фиг.3.13); 
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Фигура 3.13 Списък на функционалните икони. 

4). Добавяне чрез бутона  на избрано място. 

В резултат в лентата се появява:   
С помощта на този  инструмент  се създава Command Button – управляващ 
бутон, нужен за създаване на помощни инструменти за управление на данните 
в Excel.  

Създаване на Command Button за стартиране на макрос Обобщаване 
по магазини: 
1).Избира се с мишката бутона от лентата с инструментите и с маркера се 
посочва място в таблицата, където да се създаде бутонът. В резултат в 
таблицата се създава нов управляващ бутон  и се появява прозорец изискващ 
от нас да посочим, кой макрос желаем да стартираме (фиг. 3.14). 
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Фигура 3.14 Прозорец Assing Macro 

2). Трябва да се въведе наименование на управляващия бутон, за да бъде ясно 
какво действие извършва той. Това става, като се посочи с мишката 
управляващият бутон и се изтрие текста по подразбиране (Button1). След което 
въведете желаното от вас име в случая Обобщаване по магазини. 

Резултатът е управляващ бутон  при натискането на който се 
стартира макросът, извършващ обобщаването на оборота по магазини. 

По подобен начин се създава втори управляващ бутон, свързан с 
макроса ИзходноПоложение: 
1).Създава се управляващ бутон; 
2).Чрез Assign Macro  новосъздадения бутон се свързва  с предварително 
създадения макрос ИзходноПоложение; 
3).Преименуване на бутона на  Изходно положение. 
 

Последният управляващ бутон трябва да стартира макроса 
ОбобщаванеПоМесец: 

1). Създава се управляващ бутон 
2). Чрез Assign Macro  новосъздаденият бутон се свързва  с предварително 
създадения макрос ОбобщаванеПоМесец. 
3).Преименуване на бутона на  Обобщаване по месец. 

Резултатът е таблица с данни, която има три управляващи бутона – 2 за 
обобщаване и един за връщане в изходно положение (фиг. 3.15). 

 
Фигура 3.15 Получени управляващи бутони 

Изпробвайте действията на бутоните като спазвате последователността 
преди всяко обобщаване да се натиска бутон Изходно положение за да се 

върне таблицата в началната си форма. 
За да се предотвратят конфликти с двукратно натискане на бутон 

или пропускане на междинно натискане на бутон Изходно положение, може 
да се направи подобрение на съдържанието на макросите. Подобрението се 
състои в копиране на програмния код от макрос ИзходноПоложение и 
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поставянето му в началото на останалите два макроса. Така преди да се 
извърши процедурата обобщаване ще се връща таблицата в изходно 
положение. В този случай бутон Изходно положение става излишен. 

 
Задача 3 

Да се коригират макросите по описания по-горе начин. 
Указания за изпълнение 

1).За да се покаже съдържанието на макросите трябва да се 
използва: 
View → Macros →View  Macros и оттам да се натисне бутон 

. 
2). Да се маркира и копира програмният код на макроса ИзходноПоложение 
(текста между редовете Sub ИзходноПоложение() и End Sub) 

3). Да се постави копирания текст в началото на макросите 
ОбобщаванеПоМесец и ОбобщаванеПоМагазин веднага след ред Sub 
ОбобщаванеПо … () 
 

 Задача 4 - самостоятелна работа 
Да се създадат макроси и бутони за тяхното стартиране за 
извършване на обобщаване на данните в У1-report.xls, описани в 
упражнение 2, задача 1 и задача 2. 


